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序序序序  

Maple Software 

Maple是解決替您解決從簡單到複雜各種數學問題的強而有力系統。同時您也能在Maple環境中建立出具有專業素質的文件、報告以及互動式的計算工具。 您可以透過以下各種介面來執行並體驗到Maple的強大威力： 介面種類 介面描述 

標準（預設值） 

你可以在一個充滿特色的圖形用戶界面中輕鬆地建立電子資料來列出你全部的計算， 以及在結果上的任何誤差界限。你也可以隱藏計算過程，讓您的讀者集中注意於問題的設定以及最後結果。此外，Maple先進的格式化特徵更能讓你創造 你需要客製化文件。 因為文件是線上（live） 的，所以您可以在編輯、修改變數後，只要經由滑鼠點擊，系統就會立即算出新的結果。  標準界面有兩種模式︰ 文件（Document）模式和工作頁（Worksheet）模式。  傳統 
有記憶體有限、舊刑的電腦中，您可以使用傳統的工作頁環境。在傳統介面中並不提供標準介面中的圖形介面，它只含有一種工作頁模式。 命令行（command-line） 為解決非常複雜、解具有大批敘述性的問題，不提供圖形用戶介面。 

Maplet 應用 
一種圖形用戶界面，包含有視窗、文字輸入區域， 以及其他直觀界面，使您光用滑鼠點擊便能體會Maple的威力。你可以不需使用到工作頁進行計算並且畫出函數圖形。 

Maplesoft圖形計算機  
利用它，您只需要執行簡單的計算，就可以建立客製化、可縮放的圖形。這是只有在Maplesoft視窗中所獨有的功能。 這份導覽主要介紹如何使用標準界面。如同前面所提， 標準界面提供兩種模式︰文件模式和工作單模式。只要使用這裡種模式中的任一種，您都能創造高品質且互動性絕佳的數學文件。這兩種模式的功能及特性都相同，唯一的差別只在於預設的輸入區域不同。 

文件模式 vs. 工作頁模式  在您開始使用Maple之前，你必須先是要使用可以隱藏所有計算命令的互動介面（文件模式），或是使用顯示所有命令的介面（工作頁模式）。 
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不過無論不管您使用哪種模式，您都可以選擇 顯示或者隱藏你的計算，亦即您可以在工作頁模式裡透過Format選單選擇
Format->Create Document Block建立一個文件區塊來隱藏命令。或者您也可以在文件模式中透過Insert選單選擇
Insert->Execution Group->Before/After Cursor來顯示命令。 

文件模式 文件模式使用文件區塊（Document Block）作為預設的輸入區塊，藉以隱藏Maple語法。 文件區塊區域是用兩個三角形的符號 ，列於Maple文件的左方欄位來標示。如果看不見這個符號，您可以選擇ViewViewViewView---->Markers>Markers>Markers>Markers來顯示它。這個模式可以使您將心力集中於問題上，而不是浪費在解決問題的指令上。 舉例來說，當我們使用在Maple的智慧型選單（按右鍵點選），輸入與輸出將以等號或箭頭連接並在上面顯示運算是如何發生的，而解決此問題的命令則被隱藏起來。  當啟動標準Maple介面，則預設的模式就是文件模式。 
工作頁模式 工作頁模式將Maple提示作為預設的輸入區域，Maple輸入提示為一個紅色的「大於」符號，前面再加上一個黑色方括號 來表示，用以標示執行區域。當我們在工作頁模式中使用Maple input內容選單時，所有命令都會被顯示。 

 若要使用工作頁模式，請選擇File->New->Worksheet Mode。 

數學（Math）模式與文字（Text）模式 無論在那個介面模式，您都可以選擇要以數學模式或文字模式輸入。數學模式可以讓您輸入2-D Math，文字模式則是輸入單純文字而不能被執行，切換這兩種模式可以藉由工具列中的MathMathMathMath及TextTextTextText來選擇。 輸入模式輸入模式輸入模式輸入模式→ 數學模式數學模式數學模式數學模式（（（（預設預設預設預設））））    文字模式文字模式文字模式文字模式    介面模式介面模式介面模式介面模式↓ 文件 
� 輸入於文件區塊及傾斜游標 。 � 輸入於文件區塊及垂直游標 。 
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� 以2-D Math輸入。 
� 當使用智慧型選單，命令會被隱藏。  

� 輸入為正規文字  工作頁 
� 輸入於輸入提示及傾斜游標後 。 
� 輸入為2-D Math。  
� 當使用智慧型選單時，命令會顯示。 

 

（此模式為舊版Maple預設值） 
� 輸入於輸入提示及垂直游標後 。 
� 輸入為1-D Math，且結尾需為分號或冒號。  
� 當在output中使用智慧型選單時，命令會被顯示。 

 欲得知更多資訊，參閱文件模式vs.工作頁模式。 
使用智慧型選單、指令完結、複製及拖曳 

智慧型選單 

� Windows及UNIX：在輸入或輸出區域中按滑鼠右鍵滑鼠右鍵滑鼠右鍵滑鼠右鍵。 

� Macintosh：在輸入或輸出按住按住按住按住control再按滑鼠再按滑鼠再按滑鼠再按滑鼠。 

指令完結 在輸入命令的片段之後： 

� Windows：Ctrl +Space 或 Esc。 

� Macintosh：Command + Shift + Space或 Esc。 

� UNIX：Ctrl + Shift + Space 或 Esc。 即會出現選單，內含有包含此命令片段的所有指令供您選擇。 
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複製與拖曳 反白您想複製的區域後： 

� Windows 及UNIX：按住Ctrl並拖曳。 

� Macintosh：按住Command並拖曳。 即可將文字複製到您想要的地方。 本導覽皆下來將只以Windows的操作方式來做說明，若在範例中提及這些步驟，請自行換成您的作業系統之操作方式。更多這方面的內容請參閱智慧型選單與複製&拖曳，以及命令完結兩個章節。 

在這份導覽中 介紹了以下Maple之特性： 

� 輸入與解決問題的簡便特性。 

� 在各種介面中點擊互動，幫助您快速解決問題。 

� Maple命令及標準數學標記法。 

� 點選式的計算。 

� Help系統。 

� 入門資源。 這份入門導覽是以標準界面為基礎所建立的。您可以在Help中選擇Manuals, Dictionary, and more ->Manuals->Getting 

Started Guide來參閱這份導覽的互動版本（英文），若喜得到更多導覽、學習指南、toolbox、及其他資源，請上Maple網站 http://www.maplesoft.com/。 

主要讀者 本導覽資訊主要供初次接觸Maple的使用者入門之用。 
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第 1 章 Maple 簡介 

Don't worry about your difficulties in Mathematics. I can assure you    mine are still greater. 

~Albert Einstein 我們每天接觸數學，難度隨著我們成長而日漸增加。為了提升您學習數學的動力，Maplesoft提供了您一個讓您與數學更親近的工具：Maple！ 

1.1 在 Maple 中工作 在Maple中您可以建立強力的互動文件，Maple的環境使您只需以2D-Math輸入數學式，接著用點選的方式就能解決數學問題。您可以在同一行中輸入數學及文字，可以利用表格整理您的內容，還能插入圖片、繪圖區及電子資料表。您可問題圖像化或製成動畫，可以編輯學術論文或書籍，更能插入連結使您能與其他Maple檔案網站或電子郵件地址聯繫。 您可以嵌入並編輯圖像化的互動元件，也可以用Maple的程式語言設計問題之通解。 

 圖圖圖圖 1.1：：：：Maple作業環境作業環境作業環境作業環境 
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1.2 開始標準文件介面 在Windows中，您可以經由開始開始開始開始->所有程式所有程式所有程式所有程式->Maple 12 ->Maple 12，或者直接雙擊桌面圖示開啟Maple。開啟Maple後您首先會進入Startup對話框，他會告訴您文件模式與工作頁模式之不同，這在前面已經提過，我們將以文件模式進入。 

Startup對話框亦提供您連結許多如文件選項、help資源的更新以及其他簡介性的help頁面、Maplesoft網站上的應用資源，還有Tip of the Day（（（（每日小技巧每日小技巧每日小技巧每日小技巧））））供您參考。 您可以經由下數步驟開始您可以經由下數步驟開始您可以經由下數步驟開始您可以經由下數步驟開始文件文件文件文件模式模式模式模式：：：： 

1. 在Startup視窗選擇Blank Document。 或 

1. 關閉Startup視窗。 

2. 選擇File->New->Document Mode。 當您每次開啟一個文件，Maple都會跳出一個Quick Help彈出式選單，若您想要此選單永遠存在，請按F1。 

1.3 輸入 2-D Math 在Maple裡，輸入的預設模式就是輸入2-D Math，輸入數學式後得出的結果就跟您在教科書上看到的一模一樣。要輸入數學式有兩種方法，第一種是從鍵盤中輸入，另一種是從palette（元件庫）中拉取元件。更多與元件庫有關的資訊可參閱元件庫章節。接下來我們會提供一個關於用鍵盤輸入的範例，而範例2則是以元件庫來建立數學式。 

範例1 以鍵盤輸入並計算數學式 檢視下列檢視下列檢視下列檢視下列範例範例範例範例：：：：    

 

= 

 在這個範例中，我們經由下列方式輸入並計算 這個式子： 動作（（（（輸入數學式輸入數學式輸入數學式輸入數學式）））） 結果 

1.輸入(x。  

2.按住shift再按6，游標會移到x的上標處。 
 

3.輸入2 
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4.按→→→→鍵，將游標從上標移開。 
 

5.輸入+。 
 

6.輸入y。 
 

7. 按住shift再按6，游標會移到y的上標處。 
 

8.輸入2後再按→→→→鍵。 
 

9.輸入) 
 

10.輸入/符號，游標會移到分母處。 

 

11.輸入2。 

 

12.按→→→→鍵將游標移開分母處。 

 計算此數學式並將結果顯示在同一行計算此數學式並將結果顯示在同一行計算此數學式並將結果顯示在同一行計算此數學式並將結果顯示在同一行 

13.按住Ctrl再按 =。  

= 

 

 要執行2-D Math您可用下列任一種方式： 

� 按住Ctrl再按 =，計算結果會顯示在同一行。 

� 直接按Enter，結果會顯示在下一行並置中。 

� 右鍵點選數學式，在智慧型選單中選擇Evaluate and Display Inline。詳細內容請參考智慧型選單與複製＆拖曳。 

� 使用智慧型選單的Evaluate。 
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1.4 用捷徑（Shortcuts）輸入數學式 表表表表1.1: 輸入符號及格式的常用按輸入符號及格式的常用按輸入符號及格式的常用按輸入符號及格式的常用按鍵鍵鍵鍵 符號/格式 按鍵 範例 隱藏的乘號 
Space鍵 

 明顯的乘號 1 
* 

 分數 2 
/ 

 指數（上標）2 
^ 

 下標 2 
_ 

 操縱 方向鍵  

指令/符號完結 3 

Ctrl+Space或Esc 

 平方根 
sqrt指令完結 

 指數函數 2 
exp指令完結 

 進入/離開2-D Math模式 

工具列的Math及Text圖示 及1/4 

1 數值相乘所需。 

2 必須按方向鍵右鍵離開分母、上標或下標。 

3 需要更多資訊，請參考指令完結。 
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1.5 元件庫（Palettes） 元件庫集合了各種可以經由點選或拖曳的方式，放入您的文件中的相關元件。Maple作業環境中提供您20種以上的元件，包括有符號 、設計 、數學運算子 等。更多詳細資訊請參考元件庫。 元件庫預設為放置在Maple的左方欄位中，若您啟動Maple，元件庫未自動開啟： 

1. 從View選單中選擇Palettes。 

2. 選擇Expand Dock。 

3. 右鍵點選Palettes欄位，從智慧型選單中選擇Show All Palettes。 或是在主選單中選擇View->Palettes->Arrange Palettes顯示特定元件庫。 

範例 2 利用元件庫輸入數學式 檢視以下範例檢視以下範例檢視以下範例檢視以下範例：：：：    

 在此例中，我們將輸入 並計算此數學式 動作 結果 

1. 在Expression元件庫中點選 ，Maple會插入此符號，並且在 i 的地方反白 

 

2. 輸入i，按下Tab，反白的地方會移到k的位置，利用這個方式可以一步一步移動反白處將所需欄位填妥。 

 

3. 輸入1，按下Tab。 

 

4. 輸入10，按下Tab。 
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5. 輸入 。 

 

6. 按下Ctrl + =計算結果。 

 

1.6 工具列圖示 在Maple中，您可以藉由工具列中的Math及Text之切換，在同一行中輸入數學及文字。 

 圖圖圖圖 1.2 切換切換切換切換Math及及及及Text之圖示之圖示之圖示之圖示 

範例 3 使用工具列圖示在同一行裡輸入文字及 2-D Math 檢視以下範例檢視以下範例檢視以下範例檢視以下範例：：：： 

計算  動作 結果 輸入這個句子輸入這個句子輸入這個句子輸入這個句子：：：： 

1. 選擇Text圖示，輸入”計算計算計算計算” 

 

2. 選擇Math圖示 

3. 從元件庫中選擇   

4. 輸入1。 

5. 按下Tab，輸入5。 

6. 按下Tab。 
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7. 輸入(3x^2，按方向右鍵離開上標。 

8. 輸入+2。 

 

9. 按下Space代表相乘，輸入sqrt並按下Esc，在指令完結列表中選擇平方根的符號。您亦可從Expression元件庫中選擇平方根符號。 

 

10. 輸入x。 

11. 按下方向右鍵離開平方根。 

12. 輸入+3。 

13. 按下Space。 

14. 從Expression元件庫中選擇n次方根符號  

 

15. 輸入3。 

16. 按下Tab，輸入x)。 

17. 按下Tab，輸入x。 
 

1.7 智慧型選單及複製&拖曳 

智慧型選單 

Maple在您右鍵點選物件、敘述、或區域的時候或出現動態的智慧型選單，此智慧型選單會根據您所選擇的元件而有所不同，例如您可以操作及圖解一個數學式、增加繪圖、格式化文字、管理元件庫、建構表格等等。當您使用智慧型選單來執行一個數學式，則輸入與輸出之間會自動以箭頭或等號連結，並且以文字敘述兩者的關係。更多相關資訊請參閱智慧型選單。 

複製&拖曳 為節省輸入資訊的時間，Maple提供了拖曳的方式。您只要將需複製的地方反白，並以滑鼠拖曳到需要的地方即可，但注意這個動作會刪除原先區域的內容，若按住Ctrl拖曳的話即可避免此情形，完成複製的動作。 

範例 4 利用智慧型選單及複製&拖曳來解方程式並繪製圖形 
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檢視以下範例檢視以下範例檢視以下範例檢視以下範例：：：： 

 解方程式解方程式解方程式解方程式：：：： 

1. 輸入方程式（過程省略）。 

2, 右鍵點選此方程式，接著選擇Move to Left。 輸入輸入輸入輸入：：：： 

 結果結果結果結果：：：： 

 在連結輸入與輸出的箭頭上出現了”move to left”。 

3. 右鍵點選輸出的地方，選擇Left-hand Side。 
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輸入輸入輸入輸入：：：： 

 結果結果結果結果：：：： 
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4. 右鍵點選新的輸出，選擇 Solve->Isolate Expression for->x。 輸入輸入輸入輸入：：：： 

 結果結果結果結果：：：： 
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現在我們已經解完方程式，可以開始繪圖了。在這之前我們必須先將數學式「2x - 9」複製到一個新的文件區塊並且再使用一次智慧型選單。 

5. 從Format選單中選擇Create Document Block。 

6. 將 2x - 9 這個式子反白，按住Ctrl將其拖曳至新的文件區塊。 結果結果結果結果：：：： 
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繪製此數學式繪製此數學式繪製此數學式繪製此數學式：：：： 

7. 右鍵點選數學式並選擇Plots->2-D Plot。 輸入輸入輸入輸入：：：： 
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結果結果結果結果：：：： 

 

1.8 儲存 Maple 文件 欲儲存您所建立的這些範例，請選擇File->Save，您的Maple文件就會被存成一個.mw檔案了。 
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第 2 章 點選式互動 

Maple內建了許多特色元件，讓您不必學習任何指令就可快速解決許多問題。 

2.1 Assistants（小幫手） 

Maple針對各領域的問題，內建各種圖像化介面的小幫手，讓您不需使用任何語法。圖 2.1 為小幫手之範例。 

 圖圖圖圖 2.1    最佳化小幫手最佳化小幫手最佳化小幫手最佳化小幫手    使用 Tools ->Assistants 選單您可以選擇您所需領域的小幫手（見圖 2.2）。此外，您也可以在輸入數學式後以右鍵點選，於智慧型選單中選擇選單中出現的小幫手。 
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 圖圖圖圖 2.2 從從從從 Tool選單中執行選單中執行選單中執行選單中執行 Assistants 

圖形建築師（Plot Builder） 圖形建築師是 Maple 繪圖功能中的點選式介面，繪製的圖形依您的需要可分為圖形、互動式圖形、動畫或互動式動畫等。詳細的分類如下： 

� 2-D / 3-D plot 

� 2-D polar plot 

� 2-D / 3-D conformal plot of a complex-valued function 

� 2-D / 3-D complex plot 

� 2-D density plot 

� 2-D gradient vector-field plot 

� 2-D implicit plot 使用圖形建築師圖形建築師圖形建築師圖形建築師您可以： ① 在繪圖前指定繪圖範圍。 ② 以符號指定繪圖的終點，例如 Pi、aqrt(2)。 ③ 用下拉式選單提供繪圖選項。 以下三個圖形為圖形建築師圖形建築師圖形建築師圖形建築師的幾個主要對話框。 
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 圖圖圖圖 2.3 輸入數學式輸入數學式輸入數學式輸入數學式        圖圖圖圖 2.4 選擇繪圖形式選擇繪圖形式選擇繪圖形式選擇繪圖形式 
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 圖圖圖圖 2.5 繪圖選項繪圖選項繪圖選項繪圖選項 

範例 1 用圖形建築師繪製一個數學式 請檢視下列範例請檢視下列範例請檢視下列範例請檢視下列範例：：：：    

 在這個範例中，我們要把 畫成圖形，並且給定下列繪圖選項： 

� 改變預設的 x軸範圍。 

� 改變線的粗細。 

� 改變線的顏色。 

� 給定格線。 
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執行圖形建築師並加入以下內容執行圖形建築師並加入以下內容執行圖形建築師並加入以下內容執行圖形建築師並加入以下內容：：：： 

1. 選擇 Tools->Assistant->Plot Builder，便會出現如圖 2.3 的對話框。 

2. 在 Expression區塊按一下 Add。 

3. 在 Add/Edit Expression 對話框中輸入 sin(x)/x，接著按下 Accept Select a plot type and change the default 

x-axis rang: 

4. 按下 OK，接著會出現如圖 2.4 的對話框。或者您也可以輸入數學式後直接在它上面點右鍵，選擇 Plot->Plot Builder。 

 圖圖圖圖 2.6 使用智慧型使用智慧型使用智慧型使用智慧型選單執行圖形建築師選單執行圖形建築師選單執行圖形建築師選單執行圖形建築師 

5. 從 Select Plot Type 對話框中，您可以編輯或增加函數、選擇繪圖形式、改變 x軸範圍，或甚至預覽圖形。這裡我們選擇 2-D Plot 類型，x軸範圍從-25 到 25。 改變繪圖選項改變繪圖選項改變繪圖選項改變繪圖選項：：：： 

6. 欲編輯繪圖選項，您可以按下 Options，此時會出現 2-D Plot(plot)對話框。您可以參閱圖形建築師的 2-D繪圖選項來取得更多關於此對話框中所有繪圖選項的資訊。 

7. 在您改變選項之前請先按下 Preview看看預設選項所畫出的圖形，如此在您變更每個選項時都能看到它的變化。 
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8. 按下 Done回到 2-D Plot(plot)對話框。 

9. 在 Line區塊中，選擇右方下拉選單裡的 thick 來改變線粗。 

10. 在 Color區塊中，選擇下拉選單裡的 Blue。 

11. 在 Axes區塊中，點選 Advanced Settings 變更圖軸設定。 

12. 在 x-axis 列中，將 Gridline 選為 50，Major Gridlines 選為 5。在下一列中，將 Gridline 選為 10，Major Gridlines選為 5 

 

13. 按下 Apply確認設定，回到 2-D Plot(plot)對話框。 
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14. 在 2-D Plot(plot)對話框中選擇 Plot關閉圖形建築師並將圖形傳至文件中。 

 

圖形建築師的 2-D Plot 選項 表表表表 2.1圖形建築師中的圖形建築師中的圖形建築師中的圖形建築師中的 2-D 繪圖選項繪圖選項繪圖選項繪圖選項 繪圖選項 描述 

Expression(s) 您可以在圖形建築師中同時繪製好幾個數學式。 

x-axis 您可以編輯 x軸名稱、範圍等。 

y-axis 您可以編輯 y軸名稱、範圍等。 

Style 選擇圖形是線形式或點形式。（預設為線形式） 

Line 當您的 Style 設為線形式（line）時，可選擇線的類型及粗細。 

Symbol 當您的 Style 設為點形式（point）時，可選擇點類型（符號）及大小。 

Color 選擇圖形顏色。 

Axes 設定軸的標題，或者按下 Advanced Settings 來設定更多選項。 

View 限制或非限制的視角，設定為非限制。 

Title 加入圖形的標題。 

Caption 加入圖形的說明。 

Resolution 設定解析度，預設為 200。 
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Adaptive Ploting 機圖形再更細分，得到更好的解析度。 

Find Discontinuities 依據輸入函數的不連續性加以分段。 

Number of points 指定點的最小數量（預設為 50）。 

Fill to x-axis 將曲線與 x軸之間的區域填滿。 

Coordinate System 選擇座標系統。 

小幫手之描述 除前面說過的小幫手之外，其它的小幫手簡述於下方。有些小幫手是作為與套件指令（package commands）間的介面，關於套件指令的詳細資訊請參閱套件指令。 

� Back-Solver – 讓您可以選擇公式並輸入參數的介面，您也可以畫出圖形，藉由參數的變化看到它對此公式的影響。 

� Curve Fitting – 與 Curve Fitting 套件的介面，可以輸入許多點的資料再以曲線去擬合（fit）。 

� Data Analysis – 與 Statistics 套件的介面。 

� Import Data – 將外部檔案讀進 Maple 的介面。 

� Installer Builder – 與 InstallerBuilder 套件的介面，您可以為您的 Maple toolbox 建立安裝檔。關於 toolbox 的詳細資料請參照 http://www.maplesoft.com/developers/index.aspx。 

� Library Browser – 幫助您入某個特定 library 的介面。 

� Maplet builder – 與 Maplets 套件的介面，Maplets 套件包含許多指令，可以日您建立或顯示 Maplet 的應用程式。使用 Maplet builder 您可以定義Maplet 的配置、拖曳元件，以及設定元件的動作，甚至直接執行 Maplet 之應用程式。這個小幫手只能標準界面使用。 

� ODE Analyzer – 計算單一 ODE或聯立 ODE 的數值或符號解。 

� Optimization – 與 Optimization 套件的介面。Optimization 套件結合了許多最佳化的問題，能幫助您尋找目標函數的最大或最小直。 

� Plot Builder – 建立 2-D或 3-D 圖形，及動畫、互動式圖形的介面。 

� Scientific Constant – 與超過 2000 種物理常數及化學元件特性之介面，其中包含了相關的單位，甚至不確定性及誤差也包含在內。 

� Special Functions – 與超過 200 個特殊函數的介面，包含 Hypergeometric,、Bessel、Mathieu、Heun 及 Legendre等。 

� Units Caculator – 與超過 500 種單位轉換的介面。 

2.2 家教（Tutors） 

Maple提供了 40 種以上的互動式家教，幫助您學習 
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� Precalculus 

� Calculus 

� Multivariate Calculus 

� Vector Calculus 

� Differential Equations 

� Linear Algebra 這些家教可由 Tool->Tutors 輕易地執行，請參照圖 2.7。 

 圖圖圖圖 2.7 由工具選單執行家教由工具選單執行家教由工具選單執行家教由工具選單執行家教 有些家教也可以透過 Student 套件執行，微分方程的家教 DE Plots 可由 DEtools 套件執行。更多關於套件的內容請參閱套件指令。 

Student 套件包還了許多協助您教學與學習大學數學的子套件，這些子套件包含許多指令，另如顯示函數、計算、各種定理，以及協助您逐步顯示重要的計算過程。 

� Visualization 指令可以將各種重要觀念繪製成圖形或動畫，讓您以圖像化的方式更深入瞭解數學觀念。 

� Computation 指令能幫助您學習解決各種問題的技巧。例如 Calculus1 套件，它可以一步一步提示您如何解決微分的問題，讓您真正學習到問題的解法，當然您也可以直接顯示答案。 

� Interactive 指令幫助您探討觀念，並透過點選互動的方式解決問題。這些家教可以提供您形象化及計算指令的圖形介面。關於互動指令的範例請參照圖 2.8。 
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 圖圖圖圖 2.8 Calculus - Single Variable-> Differentiation Methods Tutor 
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2.3 智慧型選單 智慧型選單是一種動態的選單，可以應用在各個區塊，他可以讓您執行計算、操作數學式而不需用到 Maple語法。欲顯示智慧型選單，只要在物件、數學式或各區塊上按右鍵。他可以在下列區塊執行： 

� 數學式數學式數學式數學式 執行計算、操作或繪圖。 

� 繪圖區塊繪圖區塊繪圖區塊繪圖區塊 指定繪圖選項及操作圖示。 

� 表格表格表格表格 修改表格屬性。 

� 元件庫區塊元件庫區塊元件庫區塊元件庫區塊 增加、移除元件或區塊。 

� 文字區塊文字區塊文字區塊文字區塊 增加註解及格式化文字。 

� 電子表格電子表格電子表格電子表格 操作表格。 當在數學式上執行計算或操作時，將會在輸入和輸出之間產生箭號或等號，並在上面註明執行的動作。圖 2.9 及圖 2.10 為智慧型選單的兩個範例。 

  圖 2.9 右鍵點選數學式顯示應用之選單                      圖 2.10 右鍵點選圖形顯示繪圖選項 
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2.4 作業樣板（Task Templates） 作業樣板能幫助您執行特定作業，例如： 

� 執行執行方程式的數值或符號運算。 

� 建構 Maple 的物件，如函數。 

� 建立文件。 每個作業都包含了許多內容，您可以直接機其插入您的文件中。內容包含 2-D Math、指令、嵌入式元件或圖形。您必須定義您問題的參數再執行文件。圖 2.11 為作業億版的範例。 

 圖圖圖圖 2.11 瀏覽作業對話框瀏覽作業對話框瀏覽作業對話框瀏覽作業對話框 
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檢視作業 欲檢視作業： 

� 選擇 Tool->Tasks->Browse，Browse Task 對話框便會顯示並列出所有作業。 

在文件中插入作業 欲在文件中插入作業： 

1. 選擇 Insert into New Worksheet將作業插入新文件。 

2. 選擇 Insert Default Content（預設內容） 或 Insert Minimal Content（最小內容）。 

� 預設內容包含有作業的標題及描述。 

� 最小內容只含有主要元件（指令及按鈕）。 注意：您可以檢視之前插入過的作業。選擇 Tools->Tasks，之前選擇過的作業就會顯示在 Browse 選單下面。 在插入作業之前，Maple會檢查作業中的變數是否已經在您的文件中被定義過，如果是，則會跳出 Task Variable 對話框讓您可以修改名稱。 

Task Variables 對話框預設為只有當變數名稱重複時才會出現，若您要讓它在每次您插入作業時都出現，您可以： 

1. 選擇 Tools->Options。 

2. 點選 Display 標籤。 

3. 在 Show task variables on insert 下拉選單中選擇 Always。 

4. 點選 Apply to Session，若您需要對全域皆適用也可選擇 Apply to Global。 

更新變數並執行指令 在插入的作業中，他們的變數會被反白或以其他方式標示，我們必須要對其做更新的動作。 注意注意注意注意：：：：要在文件中移動這些反白的區域請按 Tab。在更新完您的變數後，請執行指令或點選按鈕。 

2.5 元件庫 在 Maple 文件環境中提供了超過 20 種元件庫，裡面包含了各種領域的項目可供您以點選或拖曳的方式加入文件中。元件庫主要包含： 

� 符號，如 等。 

� 設計，例如上標 和下標 。 
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� 數學運算子，例如定積分 ，並且您可以逐項輸入您需要的數值。 您亦可建立一個 Favorites（我的最愛）元件庫，在您常用的元件上按右鍵，選擇 Add To Favorites Palette。而
Handwriting（手寫）元件庫讓您能用手寫的方式搜尋您要的元件，請參照圖 2.12。 

 圖圖圖圖 2.12 手寫元件庫手寫元件庫手寫元件庫手寫元件庫 系統預設元件庫會列於 Maple 視窗的左方及右方的元件庫埠（palette dock）中，欲管理這些元件庫請參閱表 2.2。 表表表表 2.2 管理元件庫管理元件庫管理元件庫管理元件庫 檢視元件庫埠檢視元件庫埠檢視元件庫埠檢視元件庫埠：：：： 選擇 View->Palettes->Expand Docks。 
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增加元件庫增加元件庫增加元件庫增加元件庫：：：： 

1. 右鍵點選元件庫埠，則 Maple會在元件庫附近顯示智慧型選單。 

2. 在智慧型選單中選擇 show Palette，然後選擇您要的元件庫。 

 從元件庫埠中展開元件庫從元件庫埠中展開元件庫從元件庫埠中展開元件庫從元件庫埠中展開元件庫：：：： 按下元件庫標題旁的小三角形。 

 在元件庫埠中移動元件庫在元件庫埠中移動元件庫在元件庫埠中移動元件庫在元件庫埠中移動元件庫 點選元件庫的標題並拖曳至想要的地方。 

 展開展開展開展開/折疊元件庫埠折疊元件庫埠折疊元件庫埠折疊元件庫埠：：：： 點選元件庫區塊最左上角或最右上角的小三角形 
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表表表表 2.3 元件庫類型元件庫類型元件庫類型元件庫類型 元件庫種類元件庫種類元件庫種類元件庫種類 元件庫描述元件庫描述元件庫描述元件庫描述 數學式元件庫數學式元件庫數學式元件庫數學式元件庫 

 

Expression – 用來建立數學式，例如積分 。 

Matrix – 建立行列式，需輸入行、列數量；指定類型，例如 zero-filled（以零填滿）；指定形狀，如 diagonal（對角線）。 

Layout – 特殊設計的數學式，例如上標 。 

Components – 可在文件中嵌入圖像元件，並且可在上面撰寫程式，使按下該元件時執行所需命令。 

Handwriting – 用手寫方式搜尋符號。 

Units(SI) – 插入 SI制單位，例如 。 

Units(FPS) – 插入 FPS制單位，例如 。 

Accent – 插入標示，例如 。 

Favorites – 空白的元件庫，您可以將常用的元件放入，方便使用。 數學元件庫數學元件庫數學元件庫數學元件庫 

 

用來建立數學式 一般符號 - 相對關係 、大約相對關係 、運算子 、大運算子 、否定 、柵欄 、箭頭 、常數與符號 。 

Punctuation – 標點符號，例如註冊商標符號 ，可插入文字區塊中。 

Miscellaneous – 其他種類的符號 。 
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 字母元件庫字母元件庫字母元件庫字母元件庫 

 

Greek、Script 、Fraktur 、、、、Open Face 、、、、Cyrillic 、、、、Diacritical 

Marks 、、、、Roman Extended Upper Case 、、、、Roman Extended Lower Case 。 
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第 3 章 指令 即使 Maple 有許多特殊工具可以讓您不需輸入指令就能解決問題，但有時您可能會想透過 Maple提供的指令及程式語言來得到更佳的控制性及彈性。 

3.1 Maple 資料庫 所有指令都包含在 Maple 資料庫中，他可以分成兩部分：主資料庫（main library）及套件（packages）。 

� 主資料庫包含了常用的 Maple 指令。 

� 套件包含了在某些作業（如微積分、統計學等）中，用來解決特定類型問題的指令。例如 Optimization 套件中就包含了解決最佳化問題的指令。 

3.2 輸入指令 若您想使用指令與 Maple 互動，只要用 2-D math 模式輸入指令即可，您將會發現指令及變數名稱都是用斜體表示。Maple指令會被建構成 command(argument)的形式。 要分解一個數學式，您可以輸入： 

 要對一個式子微分，請輸入： 

 要對一個式子在[ 0,2 ]之間積分，請輸入： 

 要對一個式子做圖，請輸入： 
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 若想知道更多 Maple常用的指令，請參考 3.8節 Top Commands and Packages。 

套件指令 執行套件指令有兩個方式：長形式（long form）和短形式（short form）。 以以以以長形式長形式長形式長形式執行執行執行執行套件指令套件指令套件指令套件指令 長形式代表套件及指令名稱都為程式語言 package[command](arguments)。 

 以短以短以短以短形式形式形式形式執行執行執行執行套件指令套件指令套件指令套件指令 短形式是將套件用 with 指令將套件內所有指令先讀進來「with(package)」，若您會使用到某個套件裡的許多指令，則建議您使用短形式。當您用了 with 導入某個套件之後，該套件內的所有指令會被列出來，若想避免這個行為，可在 with(package)後面加上冒號結尾。另外，您也可以選擇用 Tool->Load Package 來讀入套件。 

 當您讀入套件之後，您就可以使用短型式的指令名稱，而且不用加上套件名稱。 
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指令完結 為了幫助您輸入程式語言以及減少輸入指令的數量，您可以使用指令完結，它可以幫您列出符合您輸入文字的所有套件、指令以及函數。 使用指令完結： 

1. 先輸入指令或套件名稱。 

2. 選擇 Tool->Complete Command或用熱鍵 Ctrl + Space或 Esc。 此時若這個指令是唯一的，他會直接插入文件內；若不是，會列出選單供您選擇。 

3. 在選單中選擇確定的指令。 

 

方程式標籤（Equation Labels） 方程式標籤可以幫助您節省輸入數學式的時間，它可以結合所有的輸出作為一個執行群組。請參照圖 3.1 及圖 3.2。 以下兩類情況系統不會提供方程式標籤方程式標籤： 

� 錯誤、警告及訊息。 

� 表格、圖像、圖形、草圖及電子表格。 系統預設方程式標籤是會顯示的，若沒有顯示，您可以： 

1. 選擇 Tool->Option->Display，接著點選 Show equation labels 選項。 

2. 選擇 Format->Labels，點選 Execution Group。 
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 圖圖圖圖 3.1 插入方程式標籤插入方程式標籤插入方程式標籤插入方程式標籤 

 圖圖圖圖 3.2 方程式標籤方程式標籤方程式標籤方程式標籤 使用方程式標籤使用方程式標籤使用方程式標籤使用方程式標籤：：：： 

1. 輸入數學式，按下 Enter，此時注意方程式標籤會出現在您的答案後面。 

2. 在另一行中輸入另一個數學式，此式必須要用到上式的輸出。 

3. 選擇 Insert->Label，或者用熱鍵 Ctrl + L 來開啟 Insert Label 對話框，輸入標籤編號，按下 OK，即可插入標籤。 

4. 按下 Enter得到結果。 欲改變方程式標籤的格式欲改變方程式標籤的格式欲改變方程式標籤的格式欲改變方程式標籤的格式：：：： 

� 選擇 Format->Labels->Label Display，接著在 Format Labels 對話框中選擇一種數字格式。 

� 或者您也可輸入文字做為標籤字首。 
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 圖圖圖圖 3.3 Format Labels對話框對話框對話框對話框：：：：增加字首增加字首增加字首增加字首 

Label Reference（（（（標籤參考內容標籤參考內容標籤參考內容標籤參考內容））））選單使您能夠在標籤名稱以及它的參考內容之間切換，請將您的游標移到方程式標籤上，選擇 Format->Labels->Label Reference。 

 圖圖圖圖 3.4 標籤參考內容標籤參考內容標籤參考內容標籤參考內容 

3.3 執行 Help 協助您使用指令與套件 

Maple 大部分的指令名稱都是很直覺的，但如果您無法定義一個指令或適當的程式語言，您可以在 help 中搜尋。Maple 的
help 系統對所有指令、範例等都做了協助頁，每個協助頁中都包含了該指令的正確程式語言：呼叫順序、參數、指令的使用描述。請參照圖 3.5。與您搜尋之指令相關的其他範例、指令等都會列在該頁下方供您連結。 啟動啟動啟動啟動 Help瀏覽器瀏覽器瀏覽器瀏覽器：：：： 

1. 您可以用以下三種方式啟動 Help 瀏覽器： 

� 選擇 Help->Maple Help。 

� 點選工具列中的 圖示。 

� 在文件中輸入?topicname，例如?LinearAlgebra，接著按下 Enter。 在在在在 help系統中搜尋系統中搜尋系統中搜尋系統中搜尋：：：： 

2. 在左欄的搜尋欄位中輸入所需字串。 

3. 系統預設會在主題中做搜尋，塑您希望搜尋內容，請點選 Text。關於更多主題搜尋的內容，請參閱使用 Help領航員。 
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4. 輸入內容並按下 Search。 

5. 左欄的 Search Result 標籤中會列出符合您搜尋條件的所有結果。若您使用的是文字搜尋，則協助頁會依照頁面中出現您的搜尋字串多寡順序排列。 如欲得知更多關於 Maple Help 系統的資訊，請參閱 Maple Help系統。 

 圖圖圖圖 3.5 搜尋搜尋搜尋搜尋 Optimization之搜尋結果之搜尋結果之搜尋結果之搜尋結果    

3.4 以文件模式檢視 Maple code 在檔案模式中，內容會以文件區塊的方式建立，文件區塊能使您隱藏用來執行計算的程式語言，如此一來可以讓讀者著重於概念的部分，而不是您用來計算的方式及程式。文件區塊一般會將 Maple code折疊隱藏起來，不過若您有需要依舊可以顯示它。 文件區塊會以兩個三角形符號標記在文字左方，此標記除了可作為區塊的邊界之外，同時也表示文件中隱藏有如註解、書籤等屬性。 啟用標記啟用標記啟用標記啟用標記：：：： 選擇 View->Markers，請見圖 3.6 
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圖圖圖圖 3.6 文件區塊標記文件區塊標記文件區塊標記文件區塊標記 檢視文件模式中的程式碼檢視文件模式中的程式碼檢視文件模式中的程式碼檢視文件模式中的程式碼：：：： 

1. 將游標置於要展開的文件區塊上。 

2. 選擇 View->Expand Document Block。 

 圖圖圖圖 3.7 展開文件區塊展開文件區塊展開文件區塊展開文件區塊 當文件區塊展開，您可以看到 Maple 用來執行計算的指令。例如圖 3.7就用了 solve 這個指令。您也可以在數學式及 solve命令之前注意到紅色的提示標誌（>），這代表這個區塊是在文件區塊外所建立的。如要再加入一個這樣的輸入區塊，請在工具列中選擇 按鈕。另外在圖 3.7 中也使用了一個方程式標籤，如想知道這方面的訊息，請參閱方程式標籤。 折疊文字區塊： 將您的游標移至文字區塊內，選擇 View->Collapse Document Block。。。。 您可以使用使用展開文件區塊的方式來學習 Maple 的指令。 

3.5 文件模式與工作頁模式 工作頁模式與文件模式在機能上幾乎完全一樣，它們同樣都可以使用智慧型選單、元件庫，輸入數學式、插入圖像…。為一不同之處只在於它們預設的輸入格式不同。 
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表 3.1 文件模式 vs. 工作表模式  文件模式 工作表模式 用文件模式啟動： 選擇 File->New->Document Mode。 

用工作表模式啟動： 選擇 File->New->Worksheet Mode。 預設輸入區塊為文件區塊  預設輸入區塊為 Maple 輸入提示  當使用智慧型選單解題時，程式語言會隱藏 當使用智慧型選單解題時，程式語言會顯示 

使用智慧型選單時，會出現「evauate and disply….」之選項，其他選項都相同。 

使用智慧型選單時，會出現「evauate and disply….」之選項，其他選項都相同。 
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3.6 數學模式 vs.文字模式 無論在文件模式或是工作表模式，其輸入的預設值都為數學模式，也就是輸入 2-D Math。而在舊版的 Maple 中，指令及數學式都是使用 Maple input或 1-D Math 輸入。 重點：若以 Maple input 輸入，命令的結尾都必須為分號或冒號。 
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 若您想以 Maple input 來輸入，請點選工具列中的 後再點選 Text按鈕  
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表表表表 3.2 數學模式數學模式數學模式數學模式 vs.文字模式文字模式文字模式文字模式 數學模式數學模式數學模式數學模式 文字模式文字模式文字模式文字模式 

Maple 預設值，可執行的標準數學記號，又可稱為 2-D數學數學數學數學輸入輸入輸入輸入。 

 

可執行的 Maple記號，又稱為 1-D數學輸入數學輸入數學輸入數學輸入或Maple輸入輸入輸入輸入。 

 由 Insert->2-D Math 執行。 由 Insert->Maple Input 執行。 當輸入 2-D 數學時，工具列中的 Math會反白。 

 

當在文字區塊輸入 Maple 輸入或文字時，工具列中的 Text會反白。  要將 2-D 數學轉為 1-D 數學，請右鍵點選數學式，接著選擇
2-D Math->Convert To->1-D Math Input。 

要將 1-D 數學轉為 2-D 數學，請右鍵點選數學式，接著選擇
Convert To->2-D Math Input。 結尾不需加任何符號。 所有輸入結尾都必須加上分號（；）或冒號（：）。 若您為 Maple 新的使用者，使用元件庫可提供您較為友善的方式來輸入數學式，並且減少您輸入上的錯誤。 

 

在 1-D 數學模式下使用元件庫，會同時告素您相關的 Maple指令。 

 在文件區塊中，文字模式會顯示正規文字。 欲局部欲局部欲局部欲局部或全域性地變更數學輸入模式或全域性地變更數學輸入模式或全域性地變更數學輸入模式或全域性地變更數學輸入模式，，，，您可以您可以您可以您可以：：：： 

1. 選擇 Tools->Options，開啟 Options 對話框。 

2. 點選 Display 標籤。 

3. 從 Input Display 下拉選單中選擇 Maple Notation。 

4. 按下 Apply to Session或 Apply Globally按鈕。 重點重點重點重點：：：：當您變更成新的輸入模式時，此新模式會成為預設值。 
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3.7 Maple 工具列選項 

Maple 工具列提供許多按鈕來幫助您使用 Maple。 表表表表 3.3 Maple工具列選項工具列選項工具列選項工具列選項 主要用途 圖示 同等作用的主選單選項或指令 插入一般文字 

 

Insert->Text。 加入 Maple 輸入 

 

Insert->Execution Group->After Cursor。 將選擇內容放入子章節 

 

Format->Indent。 移除子章節 

 

Format->Outdent。 執行工作表或文件中的所有指令 

 

Edit->Execute->Worksheet。 執行所選擇區域的指令 

 

Edit->Execute->selection。 清除 Maple內部記憶 

 

輸入 restart。 調整顯示尺寸。注意：圖形、電子表格、影像及草圖等尺寸不會改變。 

 
View->Zoom Factor。 開啟 help 系統 

 

Help->Maple Help。 對於 1-D math 及文字區塊，Tab 圖示可讓您決定 Tab 鍵是否可用作縮排功能，或讓您能於各填空區域間移動。 表表表表 3.4 Tab 圖示描述圖示描述圖示描述圖示描述 

Tab 圖示 描述 

 

Tab 圖示關閉狀態，可用 Tab 鍵於填空區域間移動游標。 

 

Tab 圖示開啟狀態，Tab 鍵可用於像一般文件中，做縮排之用途。 
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在 2-D 數學模式下，Tab 圖示是無法作用的，設定為只能用 Tab 鍵在填空區域中移動游標。 工具列圖示會視您的游標位置而有不同。例如若您的游標在輸入區塊中，則 Text 及 Math 圖示就會是亮的，而其他不能使用的圖示就會變成灰色。表 3.4 列出各種可用的工具。 表表表表 3.5 工具列圖示及其中之工具工具列圖示及其中之工具工具列圖示及其中之工具工具列圖示及其中之工具 工具列圖示選項 文字工具 

 數學工具 

 手繪工具 

 繪圖工具 

 動畫工具 
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表表表表 3.6 工具列圖示可用性工具列圖示可用性工具列圖示可用性工具列圖示可用性 區塊 可用之工具 輸入區塊 Text 及 Math 圖示 繪圖區塊 手繪及繪圖圖示 動畫區塊 手繪、繪圖及動畫圖示 畫布及影像區塊 手繪圖示 

Text 及 Math 圖示能讓您藉由適當的選擇切換，在同一行中同時輸入文字及數學。 

 當您在使用 Text或 Math 圖示時，是可以承接到下一行的。亦即您若要連續輸入文字，無須在換行之後再重新選擇一次 Text。 

Text 與 Math兩種圖示在 Maple 輸入提示時會有所不同。使用 Math 圖示的輸入會是 2-D 數學形式，而 Text則是 Maple 輸入形式。 

 若要使用 Plot和 Drawing兩個圖示，請先點選任一圖形區塊。您可以利用圖示內的工具來操作圖形，或者是描繪外型、輸入文字。若您選擇的是動畫區塊，則除了上述工具之外，您還多了一個 Animation 圖示可選擇。 至於其餘圖示在此不多做說明，您可以將滑鼠移至圖示上即會出現簡單的敘述。 
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3.8 主要指令及套件 在您檢視過前幾章的內容之後，可以粗略瀏覽一下 Maple 的主要指令及套件。 表表表表 3.7 主要指令主要指令主要指令主要指令 指令名稱 描述 

plot 及 plot3d 建立函數的 2-D或 3-D 圖形。 

solve 解一個或多個方程式，或者不等式。 

fsolve 解一個或多個方程式。（浮點數運算） 

eval 計算數學式在某一點的值。 

evalf 數值計算數學式的值。 

dsolve 解 ODE。 

int 計算定義或未定義的整數。 

diff 微分。 

limit 計算函數極限。 

sum 計算函數在某範圍的總和，可為符號運算。 

assume/is 設定變數的屬性及相對關係。 

assuming 給定假設條件計算數學式的值。 

simplify 設定數學式簡化條件。 

expand 展開數學式。 

normal 將合理函數標準化。 

convert 將數學式轉換成其他形式（如傅立葉轉換、拉普拉司轉換）。 

type 用來判斷數學式或敘述是屬於那個分類（例如浮點樹、合理數）。 

series 級數展開。 

map 將參數丟進函數中。 
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關於詳細的指令清單可以從Help->Manuals,    Dictionary, and more->List of Commands找到。 表表表表 3.8 主要套件主要套件主要套件主要套件 套件名稱套件名稱套件名稱套件名稱 描述描述描述描述 

CodeGeneration 包含將 Maple code轉換成 C、Fortran、MATLAB等語言的指令及子套件。 

LinearAlgebra 包含建構矩陣、向量，以及解決線性代數問題的指令。 

Optimization 包含解決最佳化問題的指令。 

Physics 包含大部分數理問題所需的表達法及相關操作。 

RealDomain 提供一個環境讓 Maple 在實數域中運作。 

ScientificConstants 提供許多物理常數的值，例如光速及鈉的原子量，此外也包括了這些常數的單位，讓您對其內容有更完整的瞭解。它還提供了單位比對，讓您檢查答案是否正確。 
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ScientificErrorAnalysis 包含一些附有誤差的數值，能讓您做各種誤差的分析。 

Statistics 包含數值分析與資料分析的各種數據，此外還有廣域的分析範例，例如數值及圖像資料分析、模擬及曲線擬合。 

Student 包含用來教學或學習大學數學的各種子套件，還有能看到指令的函數、計算及定理、重要計算的逐步解說。 

Student 套件包含有下列子套件： 

� Calculus1 – 單變數的微積分。 

� LinearAlgebra – 線性代數。 

� MultivariateCalculus – 多元微積分。 

� Precalculus – 微積分學前課程。 

� VectorCalculus – 多元向量微積分。 

Units 包含單位轉換的指令及提供帶有單位的運算環境。它包含了約 300 種不同單位名稱（例如
meters 及 grams）以及超過 500 種帶有文字敘述的單位（例如 standard miles 及 U.S. survey 

miles）。此外它還有兩個單位樣板，讓您能輸入單位並立刻得到其描述。 

VectorCalculus 集合了多元及向量微積分的運算子，並且定義了大量的正交座標系統，所有在此套件內的計算都濃在這些座標系統上執行。它也可以讓您非常輕易的新增您習慣的正交座標系統並使用在您的計算中。 完整的套件列表您可以在 Help->Manuals, Dictionary, and more->list of Packages 中找到。 而關於本導覽中所有項目的更詳細資訊，請參照 Maple使用者指南使用者指南使用者指南使用者指南。 您可以經由下列步驟進入 Maple 使用者指南使用者指南使用者指南使用者指南： 

1. 選擇 Help->Manual, Dictionary, and more。 

2. 選擇 Manual->User Manual。 
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第 4 章 Maple Help 系統 

Maple提供了量身定做的 help 系統，內含有約 5000 個參考頁。Help 系統為使用 Maple 程式語言及學習 Maple 各項功能的一個便利資源。 

4.1 使用 Maple Help 系統 要使用 Maple help 系統有以下方式： 

� 選擇 Help->Maple Help。 

� 按下工具列中的 。 

� 在文件中輸入?topic，例如?LinearAlgebra，再按下 Enter。 在 Maple help 系統為含有兩個欄位的分離視窗。左方欄位包含 Help Navigator（領航員），能讓您搜尋需要的項目；右方欄位顯示最終搜尋結果，例如特定的協助頁。 
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圖 4.1 範例協助頁 

Maple 中每個協助頁會列出指令的呼叫方式、參數、描述及範例。有些協助頁也能讓您連結到其他協助頁或定義字典。連到協助頁的超連結為藍色，連到定義字典的則為咖啡色。 

4.2 使用 Help 領航員 

Help 領航員包含下列主題或內文搜尋： 

� 主題主題主題主題（（（（Topic））））搜尋會依照主題與您輸入內容的符合程度為準列出列表。 

� 內文內文內文內文（（（（Text））））搜尋會依照內文出現您輸入內容的次數多寡為準列出列表。 

� 您可以設定從整個 help 系統中搜尋，或是由 Resources 下拉選單中選擇只從協助頁、作業、定義、家教及導覽中搜尋。 

� 搜尋結果會顯示在左邊欄位的 Search Results 標籤中。此外，按下 Table of Contents（（（（目錄目錄目錄目錄））））標籤則可以瀏覽 help系統的所有主題之結構。 

Help 系統目錄 若要顯示在右方欄位中的潛在符合項目，可以按下前方有下列圖示的主題： 

 
資料夾圖示代表主題可以被展開，裡面還有許多次主題 

 
問號圖示代表這是一個協助頁，選擇後會在右邊欄位顯示相關協助頁。 

 
WS 圖示代表此為範例工作頁，選擇後會在 Maple 文件中開啟一個新分頁。 

 
D 圖示代表定義，選擇後會顯示相關定義。 

 
T 圖示代表作業樣板，選擇後會顯示相關作業樣板在右邊欄位。 

 
M 圖示代表導覽，選擇後會在 Maple 文件中開啟新分頁。 

4.3 以文件方式瀏覽協助頁 在協助頁中，範例是無法執行的。Maple help 系統可以讓您在文件中開啟協助頁，如此一來您便可執行裡面的指令。 在文件或工作業中開啟協助頁在文件或工作業中開啟協助頁在文件或工作業中開啟協助頁在文件或工作業中開啟協助頁：：：： 
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� 當協助頁開啟在 help 系統的右邊欄位時，從 View 選單中選擇 Open Page as Worksheet，便會開啟一個新的工作業視窗了。 

 
此外，您亦可在 help 系統的工具列中點選 open the current help page in a worksheet window 圖示。 

4.4 複製範例 除了將整個協助頁以文件方式開啟，您亦可只複製範例範例範例範例（（（（Examples））））部分。 複製範例複製範例複製範例複製範例：：：： 

1. 當協助頁顯示於 help 系統右方欄位時，從 Edit 選項中選擇 Copy Example。 

2. 關閉或將 Help 領航員最小化，回到您的文件。 

3. 在您的文件中，將由標誌於您將貼上範例的位置。 

4. 從 Edit 選單中選擇 Paste，則協助頁中的範例部分就會能在您的文件中執行其內容了。 
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第 5 章 使用 Maple 

Maple 是一個非常強力的應用程式，它有非常強大的資源來引導並協助您解決各種類型的問題。 

5.1    Maple 的點選式數學    若您曾使用過 Maple，您會發現新的 Maple 結合了許多優點並且替新使用者除去了許多學習上的困難。拖曳式的機能、智慧型選單、內建家教、指令完結以及超過 20 種類的元件庫，您一定未曾如此輕鬆地使用過 Maple。本章會展示用各種不同的方法來解相同的問題。 

範例 1 繪製一個函數及它的導數之圖形 

 以智慧型選單解題以智慧型選單解題以智慧型選單解題以智慧型選單解題：：：： 

1. 輸入數學式 。 複製式子並以計算其導數複製式子並以計算其導數複製式子並以計算其導數複製式子並以計算其導數（（（（derivative）：）：）：）： 

2. 選擇 Format->Create Document Block 插入新文件區塊。 

3. 反白原式，按住 Ctrl將其拖曳至新文件區塊。 

4. 右鍵點選數學式並選擇 Differentiate->x。 複製導數並計算二階導數複製導數並計算二階導數複製導數並計算二階導數複製導數並計算二階導數：：：： 

5. 插入新文件區塊，反白剛才求得之一階導數，按住 Ctrl將其拖曳到新的文件區塊。 

6. 右鍵點選一階導數並選擇 Differentiate->x。 結果結果結果結果：：：： 

 將此數學式繪製成圖將此數學式繪製成圖將此數學式繪製成圖將此數學式繪製成圖：：：： 

7. 插入新文件區塊，反白原式，按住 Ctrl 拖曳到新文件區塊中。 
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8. 右鍵點選之，並選擇 Plot->Plot Builder。 

9. 在 Interactive Plot Builder：：：：Select Plot Type 對話框中，將 x Axis 範圍改成-Pi..Pi。 用智慧型選單繪製圖形用智慧型選單繪製圖形用智慧型選單繪製圖形用智慧型選單繪製圖形：：：： 將一階級二接導數加入圖形中將一階級二接導數加入圖形中將一階級二接導數加入圖形中將一階級二接導數加入圖形中 

10. 反白一階導數，按住 Ctrl 拖曳至圖形區塊中，二階導數也用同樣方式處理之。注意：您也可以將圖形框中用滑鼠拉出框外，此時會產生新的圖形框繪製此圖形。 新增圖例新增圖例新增圖例新增圖例（（（（Legend）：）：）：）： 

11. 右鍵點選圖形區域並選擇 Legend->show Legend。 

12. 在圖利中雙點 Curve 1，並且注意您工具列中的 確實被選取。刪除原先的文字，選擇 ，他可以讓您輸入 2-D Math。輸入原來的數學式 ，並且對 Curve 2 及 Curve 3做同樣的處理。 新增標題： 

13. 選擇工具列中的 ，若無法選取，請先點選一下圖形框。 

14. 點選 Drawing 工具列中的 。 

15. 點選圖形框，此時會出現文字框，切換 Text 及 Math 在文字框內輸入文字與 2-D Math。當選取 Text 時輸入”Plot the 

expression”，點選 Math然後輸入數學式，再點選 Text 輸入”and its derivatives”。 

16. 點選文字框則其外框會變明顯，您可現在可以用滑鼠將文字框變形並將其拖曳到圖形框的任何地方。 
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結果結果結果結果：：：： 

 以家教以家教以家教以家教（（（（Tutor））））解題解題解題解題：：：： 

Student Calculus 1 套件包含一個叫Derivatives 的家教，可以顯示一個數學式與其導數的圖形，在這一節中我們就使用這個家教來解決前面那個問題。 

1. 選擇 Tools->Load pakage->Student Calculus 1 讀取此套件。 結果結果結果結果：：：： 

Loading Student:-Calculus 1 

2. 按住 Ctrl 拖曳數學式到空白文件區塊。 

3. 右鍵點選數學式並選擇 Tutor>Calculus->Single Variable->Derivatives。注意：若我們沒有做第 1 個步驟，Tutor 選單此時是不會出現的。 

Derivatives 家教會顯示此數學式及其導數之圖形，右邊欄位則會有各個顏色之圖形所代表的數學式。請參照圖 5.1。 
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 圖 5.1 Derivative（導數）家教 

4. 選擇選框使 f’’(x)出現在圖形中，按下 Display產生變更。 

5. 您可以改變數學式、範圍，或是繪圖選項，記得每變更一個選項都按下 Display 來看看圖形的變化。當完成您想要的圖形，按下 Close將圖形畫在文件中。 結果結果結果結果：：：： 
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從作業樣板從作業樣板從作業樣板從作業樣板（（（（Task Template））））中執行中執行中執行中執行 Tutor：：：： 

Maple 也配備了作業樣板幫助您解決問題。 

1. 執行 Tools->Tasks->Browse 進入作業樣板。 

2. 在作業樣板的內容對話框中，展開 Caculus->Derivatives->Graph f(s) and Its Derivatives。 

3. 按下對話框上方的 Insert Minimal Content將樣板插入目前文件中。 

4. 在 f(x)區域中輸入新的數學式。 

5. 輸入時間區段。 

6. 按下 Launch Differentiation Tutor 執行上個例子中的家教。 

7. 完成後按下 Close，此數學式及其導數的圖形會出現在繪圖區域中。 結果： 
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範例 2 在線性方程式中對 x 求解 對 中的 x 求解 透過方程式求解器透過方程式求解器透過方程式求解器透過方程式求解器（（（（Equation Manipulator））））求解求解求解求解 

Maple 中有一個功能可以讓您一步一步解出一個數學式，您可以在智慧型選單中找到這個功能。 

1. 按住 Ctrl將數學式拖曳到新的文件區塊中。 

2. 右鍵點選方程式並選擇 Manipulate Equation，則會出現 Manipulate Equation 的對話框。請參照圖 5.2。 

 圖圖圖圖 5.2    求解方程式求解方程式求解方程式求解方程式    
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將所有項集中在左邊將所有項集中在左邊將所有項集中在左邊將所有項集中在左邊：：：： 

3. 在 Addition區域中，Froup terms 可以幫助我們做這個工作。請確認您以選擇預設的 left 後按下 Do即可。 展開左方的方程式展開左方的方程式展開左方的方程式展開左方的方程式：：：： 

4. 在 Miscellaneous Operations區域，於下拉式選單中選取指令 Expand，按下 Do。。。。 將方程式因式分解將方程式因式分解將方程式因式分解將方程式因式分解：：：： 

5. 在同一個下拉式選單中選擇 factor 並按下 Do 將這些步驟傳回並關閉對話框 

6. 按下 Return Steps。 結果： 

 

7. 按住 Ctrl 拖曳分解後之方程式至新的文件區塊。 

8. 右鍵點選方程式並選擇 Solve->Solve for Variable->x。 結果： 

 快速解法快速解法快速解法快速解法：：：： 欲快速解決問題，可以使用智慧型選單。 

1. 按住 Ctrl 拖曳方程式至新文件區塊。 

2. 右鍵點選數學式並選擇 Solve->Solve for Variable->x。 結果： 

 點選式互動解法： 利用方程式標籤，我們可以方便地隨自己的意思對方程式做運算。 
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1. 按住 Ctrl 拖曳方程式至新的文件區塊並按下 Enter。 將所有項集中在右邊，我們必須先兩邊同減 。 

2. 按下 Ctrl + L，在對話框中輸入該方程式之標籤編號。當方程式標籤插入後輸入 。 

3. 重複第 2 個步驟，兩邊同減 。 結果： 

 接著我們要使用 Maple 的 expand（展開）、factor（因式分解）及 solve（求解）指令來決問題。 

4. 使用 Maple 的 expand 指令及該方程式的標籤來展開方程式。 

5. 輸入 expand(。 

6. 按下 Ctrl + L 並輸入先前得到的方程式標籤編號。 

7. 輸入後括號 )。 

8. 重複第 5 到 7 個步驟來解題。 結果： 
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圖解圖解圖解圖解 至今我們已經用了許多方法來解題，現在我們用繪圖的方式來檢視結果。 我們必須先將方程式變成單一的數學敘述方能繪圖我們必須先將方程式變成單一的數學敘述方能繪圖我們必須先將方程式變成單一的數學敘述方能繪圖我們必須先將方程式變成單一的數學敘述方能繪圖。。。。 

1. 將方程式複製到新的文件區塊，按下 Enter。 

2. 右鍵點選輸出，並選擇 Move to Left，可注意在輸入及輸出處點選右鍵時智慧型選單的不同。 

3. 右鍵點選輸出，並選擇 Laft-hand Side。 

4. 右鍵點選輸出，並選擇 Expand。 結果結果結果結果：：：： 

 現在方程式已經化簡，可以對它作圖了。 

5. 按住 Ctrl 拖曳輸出到新的文件區塊。 

6. 右鍵點選數學式並選擇 Plot->2-D Plot。 

7. 右鍵點選圖形並選擇 Axes，接著選擇 Properties，在 Axes Properties 對話框的 Horizontal 標籤中，取消 Use data 

extents 的選取，並將 Range min 及 Range max 分別變更為 0 及 5。按下 Vertical 標籤，取消 Use data extents之選取，並將 Range min 及 Range max 分別變更為 5 及 10。 
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結果結果結果結果：：：： 

 

範例 3 二次方程式 找出方程式 在 區間中的所有解。 圖解 

1. 按住 Ctrl 拖曳方程式至空白文件區塊並按下 Enter。 

2. 右鍵點選方程式並選擇 Left-hand Side。 

3. 右鍵點選方程式並選擇 Plot->Plot Builder。 

4. 適當修改圖形範圍。 
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結果結果結果結果：：：： 

 利用作業樣板求解利用作業樣板求解利用作業樣板求解利用作業樣板求解：：：： 

1. 按住 Ctrl將方程式拖曳至空白文件區塊。 

2. 從 format 選單中選擇 Tasks->Browse，展開 Algebra 資料夾，選擇 Solve Analytically in a Specified Interval。 

3. 按下 Insert Minimal Content。 

4. 用本例的數學式取代原先的。 

5. 注意：可用方程式標籤來表示計算結果。 
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結果結果結果結果：：：： 在特定區間的解析解 輸入數學式： 

 在特定區間內尋找根： 

 將根以浮點數形式表示： 

 解析解解析解解析解解析解 

1. 按住 Ctrl 拖曳方程式至空白文件區塊。 

2. 右鍵點選之，並選擇 Left-hand Side。 

3. 按住 Ctrl將輸出拖曳至空白文件區塊。 

4. 右鍵點選之，並選擇 Factor。 

5. 按住 Ctrl將第一項因式拖曳至空白文件區塊。 

6. 右鍵點選之，並選擇 Solve。 

7. 按住 Ctrl將第一項因式拖曳至空白文件區塊。 

8. 從數學式中將 x去除。 

9. 按住 Ctrl 拖曳，將結果取代 x 之值。 

10. 右鍵點選之，並選擇 Evaluate and Display Inline。 

11. 按住 Ctrl 拖曳第二項因式至空白文件區塊。 

12. 右鍵點選之，並選擇 Solve。 
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結果結果結果結果：：：： 

 

範例 4 反函數 若 ，請找出並畫出 。 將定義圖形化將定義圖形化將定義圖形化將定義圖形化 反函數的圖形即為將橫座標與縱座標互換。 

1. 在空白文件區塊中輸入[ f(x),x ]接著按下 Enter。 

2. 右鍵點選輸出，選擇 Plots->Plot Builder。 

3. 在 Plot Builder 中，選擇 Plot Type 對話框，並確定 Select Plot區域中的 2-D Parametric Plot已被選取。 

4. 將 x 範圍調整為[0,1]區間。 

5. 選擇 Plot將圖形傳回文件中。 
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結果結果結果結果：：：： 

 

6. 按住 Ctrl 拖曳 f(x)數學式至圖框中，請注意此時圖軸的變化。 

7. 按住 Ctrl將 x 數學式拖曳至圖框中。 此時的圖形即為 ，調整 x 與 y軸的範圍。 

8. 右鍵點選圖形並選擇 Axes->Properties。 

9. 在 Axes Properties 對話框中，取消 Use data extents 之選項，並將範圍改成[0,2]。 

10. 點選 Vertical 標籤並重複步驟 10，按下 OK確認設定並關閉對話框。 結果結果結果結果：：：： 
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使用家教解題使用家教解題使用家教解題使用家教解題：：：： 

1. 從 Tools->Load Package 選單讀入 Student Calculus 1 套件。 

2. 按住 Ctrl 拖曳 f(s)之數學式至空白文件區塊中。 

3. 右鍵點選並選擇 Tutors->Calculus-Single Variable->Function Inverse，請參照圖 5.3。 

 圖圖圖圖 5.3 Function Inverse 

4. 調整範圍。 

5. 從 Formula of the Inverse區域中選擇適當分支。 結果： 
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範例 5 積分方法 

計算積分式 ，並用 替換。 積分之快速解法積分之快速解法積分之快速解法積分之快速解法：：：： 

1. 按住 Ctrl 並拖曳積分式至空白文件區塊。 

2. 右鍵點選之並選擇 Evaluate。 結果： 

 利用利用利用利用積分家教積分家教積分家教積分家教（（（（Integration Methods Tutor））））求解求解求解求解：：：： 

1. 選擇 Tools->Load Package->Student Calculus 1 讀入 Student Calculus 1 套件。 

2. 按住 Ctrl將積分式拖曳到空白文件區塊。 

3. 右鍵點選之，並選擇 Tutors->Calculus Single Variable->Integration Methods。 

4. 選擇 Change 並輸入 變更數學式。請參照圖 5.4。 

5. 點選 constant multiple。 

6. 點選 revert。 



71 

 

 圖圖圖圖 5.4 積分家教積分家教積分家教積分家教 

7. 關閉家教視窗。 結果結果結果結果：：：： 

 以第一定理求解以第一定理求解以第一定理求解以第一定理求解 

1. 按住 Ctrl 拖曳積分式至空白文件區塊。 

2. 右鍵點選並選擇 Evaluate at a point，在出現的對話框中輸入 x=sin(u)。 

3. 右鍵點選並選擇 Simplify->Symbolic。 

4. 按住 Ctrl將結果拖曳至空白文件區域，按下 Enter。 

5. 將方程式之標籤與 sin(u)相乘，並按下 Enter。 
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6. 右鍵點選之，並選擇 Constructions->Integral->u。 將原定義代回將原定義代回將原定義代回將原定義代回：：：： 

7. 在空白文件區塊中放入 x=sin(u)，按下 Enter。 

8. 右鍵點選之，並選擇 Solve->Solve for a Variable->u。 結果： 

 

範例 6 初始值問題 解下列初始值問題： 

 在同一個座標平面中繪出 y(t)及 y’(t)。 用用用用 ODE分析分析分析分析小幫手小幫手小幫手小幫手（（（（Analyzer Assistant））））求解求解求解求解 

ODE 分析小幫手能讓您以數值或符號方式求解並繪出圖形。 

1. 按住 Ctrl將 ODE 拖曳至空白文件區塊中。 

2. 右鍵點選之，並選擇 Solve ODE Interactively，此時 ODE 分析小幫手會出現，並且您的 ODE會自動插入其中。 
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 圖圖圖圖 5.5    ODE分析分析分析分析小幫手小幫手小幫手小幫手    要插入初始條件要插入初始條件要插入初始條件要插入初始條件：：：： 

3. 在 Conditions區域中按下 Edit，會開啟 Edit Condition 對話框。 

4. 在 Add Condition區域，於下拉選單中選擇 y，並在第一個文字欄位中輸入 0，第二個文字欄位中輸入 2，按下 Enter。您輸入的應該要和圖 5.6 所示相同。 

5. 輸入 y’的初始條件，於下拉選單中選擇 y’，並在第一個文字欄位中輸入 0，第二個文字欄位中輸入 1，按下 Add，接著點選 Done關閉對話框並回到主視窗。 
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 圖圖圖圖 5.6 編輯條件編輯條件編輯條件編輯條件（（（（Edit Condition））））對話框對話框對話框對話框 

6. 點選 Solve Numerically。。。。 欲解此初始值問題欲解此初始值問題欲解此初始值問題欲解此初始值問題：：：： 

7. 按下 Solve。 欲繪製此答案之圖形欲繪製此答案之圖形欲繪製此答案之圖形欲繪製此答案之圖形：：：： 

8. 按下 Plot。 
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 圖圖圖圖 5.7 數值解之視窗數值解之視窗數值解之視窗數值解之視窗 欲改變繪圖選項欲改變繪圖選項欲改變繪圖選項欲改變繪圖選項：：：： 

9. 點選 Plot Condition按鈕來修改預設值。 

10. 按下 Quit關閉 ODE 分析並將圖形傳回文件中。 
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結果結果結果結果：：：： 

 

5.2 微積分範例 

Maple 是一個擁有許多資源，能有效引導您的強力應用軟體。下面的範例將會提供您使用 Maple 資源及程式的一些方案。 當您使用 Maple去求解一個問題，請考慮以下步驟： 

1. 簡潔敘述您的問題。 

2. 取得能幫助您解題的 Maple 資源。 

問題 方案方案方案方案 A：：：： 您的公司設計了一個新的礦泉水瓶子，容量必須為 18盎司且高度是限制住的，您的設計已經包含了取線的形狀及大小，只差要知道半徑，您需要的是 Volume of Revolution 這個工具。 
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方案方案方案方案 B：：：： 您想要教導學生關於 Volume of Revolution 的觀念，以及計算並畫出 f(x),a≦x≦b由所繞出之體積。 

 圖圖圖圖 5.8    解題之流程圖解題之流程圖解題之流程圖解題之流程圖    

檢視現有工具：家教 一開始您可用 Tool 選單中的 Tutor 來解這樣的問題。 執行解決執行解決執行解決執行解決 Volume of Revolution問題的家教問題的家教問題的家教問題的家教：：：： 

1. 由 Tools 選單中選擇 Tutors，接著選擇 Calculus-Single Variable。 

2. 選取 Volume of Revolution 選項。此外亦可由下列指令開始。 

 接著 Volume of Revoution Tutor會出現，請參照圖 5.9。使用此家教輸入您的函數及區間，同時觀察並操作相關的圖形。此外我們也可以看到您所輸入或選擇的動作之 Maple 指令。 
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 圖圖圖圖5.9 5.9 5.9 5.9 Volume of Revolution Tutor 當您關閉此家教，您的圖形將會插入您的工作頁中。 
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檢視現有工具：作業樣板    

1. 從 Tools 選單中選擇 Task->Browse，則會開啟 Browse Tasks 對話框，其中會列出所有作業的列表，並且分門別類以幫助您快速找到您想要的作業樣板。 

2. 展開 Calculus 資料夾。 

3. 從列表中選擇 Volume of Revolution，則 Volume of Revolution 樣板會顯示在 Browse Tasks 對話框之右欄中。 

4. 選擇 Insert into New Worksheet 選框。 

5. 點選 Insert Default Content，在插入此樣板之前 Maple會確認其中的參數是否與您工作頁中已定義的參數重複，若重複，則會開啟 Task Variables 讓您修改參數名稱。接著樣板內容就會插入您的文件中，詳見圖 5.10。 

 圖圖圖圖 5.10 插入作業樣板插入作業樣板插入作業樣板插入作業樣板 

6. 當作業樣板插入後，參數部分會被反白，您可使用 Tab 鍵在各個反白區域間移動。當您設定好參數之後，按下 Enter即可執行樣板中的指令。 

檢視說明：協助頁及範例工作頁 

help 系統提供了所有指令的資訊。 要使用協助頁要使用協助頁要使用協助頁要使用協助頁：：：： 

1. 從 Help 選單中選擇 Maple Help。 

2. 在 search欄位中輸入 volume of revolution，接著按下 Search，搜尋結果將會包含有協助頁、定義及相關的家教協助頁。 

3. 重新檢視 Student[calculus1][Volume of Revolution]協助頁中的呼叫順序、參數及敘述等項目。 

4. 將其中範例複製到您的工作頁中：從 Edit 選單中選擇 Copy Example。 

5. 關閉 Help 系統。 

6. 在您的文件中選擇 Edit->Paste，範例將複製到您的文件中。 
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7. 執行範例並檢視結果。 執行範例工作頁執行範例工作頁執行範例工作頁執行範例工作頁：：：： 

1. 在工作頁中輸入?index/examples，則 Example Worksheet Index會開啟。 

2. 展開 Calculus 主題。 

3. 點選 Calculus1IntApps連結，會開啟 Calculus1 : Applications of Integration 工作頁。 

4. 展開 Volume of Revolution 主題。 

5. 檢查並執行範例。 

 圖圖圖圖 5.11 範例工作頁範例工作頁範例工作頁範例工作頁 

檢視其他可用工具：應用中心 

Maple 應用中心包含了由使用者提供的免費應用範例，舉凡數學、教育、科學、工程、電腦科技、統計、資料分析、金融、通訊、繪圖等類別都有。 執行有關執行有關執行有關執行有關 volume of revolution之免費範例之免費範例之免費範例之免費範例：：：： 

1. 進入 Maplesoft 網站，http://www.maplesoft.com。 

2. 在主頁面的選單中選擇 User Community，接著選擇 Application Center。 

3. 在旁邊的選單中選擇 Education PowerTools。 

4. 點選 Calculus II連結，接著選擇 Calculus II: Complete Set of Lessons連結。 

5. 從 Options區域點選 Download Maple Worksheet。詳見圖 5.12。 

6. 以訪客或會員身份登入。 

7. 下載.zip檔案。 

8. 將 L2-volumeRevolution.mws檔案解壓縮。 
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9. 執行此工作單並檢視其結果。 

 圖圖圖圖 5.12 Maple 應應應應用中用中用中用中心心心心：：：：PowerTools 
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第 6 章 可用資源 

6.1 線上協助及範例 

協助頁 線上協助系統能幫助您找到有關特定主題、指令、套件等之資訊，您可以用三種方式啟動 help 系統。 

� 從 Help 選單中選擇 Maple help。 

� 從工具列中選擇 Help 圖示 。 

� 在文件或工作頁中輸入?topicname，例如?LinearAlgebra，接著按下 Enter。 

字典 包含了超過 5000 種數學及工程項目以及超過 300 種圖形。 

1. 由 Help 選單中選擇 Maple Help。 

2. 在 Resources 下拉選單中選擇 Definition。 

3. 輸入關鍵字或依字母展開列表。 

應用及範例工作頁 應應應應用用用用 應用樣本會示範如何用 Maple 來對問題求解。有些應用能讓您輸入數據或是包含一些動畫供您執行，不過他們的主要用途還是作為示範之用。這些應用樣本的主題包括：DC Motor Control Design、Digital Filter Design、Frequency Domain System 

Identification、Harmonic Oscillator等。 範例範例範例範例 範例樣本是可執行的文件，他包含了一些主題，能為您示範如何用程式語言及使用者介面，讓您的將複雜的問題簡化或具象化。您可以複製或修改您需要的範例。內容包括有：Algebra、Calculus、Connectivity、Discrete Mathematics等。 

� 從 Help 選單中選擇 Manuals, Dictionary, and more->Applications and Examples。 
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6.2 Maple 家教及新使用者藍圖 

Maple導覽導覽導覽導覽（（（（Tour）））） 

Maple Tour中包含一些介面，內容涵蓋下列主題：Ten Minute Tour、Numeric and Symbolic Computations、Matrix 

Computations、Differential Equations、Statistics、Programming and Code Generation、Units and Tolerances及
Education Assessment、Maple T.A。 

� 從 Help 選單中選擇 Take a Tour of Maple。 新使用者新使用者新使用者新使用者藍藍藍藍圖圖圖圖 幫助您迅速尋找到最有效率的解題方法，或學習主要內容。 

� 從 Help 選單中選擇 Manuals, Dictionary, and more->New User Roadmap。 

6.3 網站資源 

歡迎中心 

Maple 網站提供了所有關鍵的使用者資源，在歡迎中心您可以檢視範例應用、參與用戶討論、執行額外內容等。此外，您更可以使用支援服務、觀看訓練影片、下載使用者指南及許多內容。 

1. 前往 http://www.maplesoft.com。 

2. 在首頁選單中點選 Site Resources->Welcome Center。 

教師資源中心 教師資源中心是用來使您在 Maple 的教學上能獲得更多的經驗，它提供了應用樣本、課程素材、訓練影片、白皮書、電子書籍及一些小技巧等。 

1. 前往 http://www.maplesoft.com。 

2. 在首頁選單中點選 Site Resources->Teacher Resource Center。 

應用中心 

Maple 網站中與數學、教育、科學、工程、電腦科學、統計、一料分析等相關的各種免費應用，許多應用都有各種語言的版本。 

1. 前往 http://www.maplesoft.com。 

2. 在首頁的選單中點選 User Communication->Application Center。 
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強力工具（PowerTools） 

Maple 網站中由各領域專家所提供的課程或附加套件，能幫助使用者配置 Maple 以搜尋特定領域的應用。 

1. 前往 http://www.maplesoft.com。 

2. 在首頁的選單中點選 User Communication->Application Center。 

3. 於網頁旁邊的欄位中點選 Research PowerTools or Education PowerTools。 

訓練 

Maple提供了充足且全面性的順練素材，舉凡訓練影片、研討會到可下載的文件等都囊括在內，您可以任意選擇使您最有效的學習方法。此外，無論您是老手或是新使用者，我們都可以提供您最適合的訓練課程。 

1. 前往 http://www.maplesoft.com。 

2. 在首頁的選單中點選 Site Resources->Training。 

Maple 社群 此頁面用來分享一些 Maple 及相關產品的經驗、技術與意見，還有最常被使用的主題等。 

1. 前往 http://www.maplesoft.com。 

2. 在首頁的選單中點選 User Community->MaplePrimes。 

技術支援 包含了關於 FAQ、下載、產品包及連結等，還有申請技術支援的格式供您填寫。 

1. 前往 http://www.maplesoft.com。 

2. 在首頁的選單中點選 Customer Support->Support & Customer Service。 


